How do I resolve the 'Error acquiring OAuth2 Token' on my Salesforce integration?

How to fix the 'Error acquiring OAuth2 Token' on the 'Establish OAuth2 Connection' Tab for Salesforce.

 
Screenshot 2022-06-14 at 15.49.13
 
To amend this issue, you'll need to reset the integration between both Salesforce and New/Mode so the access token can be acquired successfully.

To reset the integration between Salesforce and New/Mode, follow the steps below:

1. Log out of your Salesforce account.
2. In your New/Mode dashboard, open the Integrations tab.
3. Find Salesforce, click on the down arrow on the right side and click on 'Add another'.
4. Give this new integration a different Title (just 'Salesforce 2' would do)
5. In the Host field enter: https://[ENTERORGSLUG].my.salesforce.com ('lightning' domains don't work)
6. Click on 'Save'.
7. You'll be asked to log into your Salesforce account to authorize the connection. Please accept any prompts you see.
8. Go back to the new integration and check the 'Establish OAuth2 Connection' tab to confirm that there's a connection (the message should be something like 'An existing OAuth2 access token is available on this service').
9. Once you've confirmed that this new integration works, open one of your actions, add this new integration at the end of the Basic Configuration page, and click 'Save & Next' to save the changes.

Once you have reconnected your template to your SalesForce action, you should now see SF fields as available when setting up the mapping on your New/Mode components. If you're still running into access issues after following the above steps, please let us know.